GitHub header
Incident with Codespaces
Incident Report for GitHub
Resolved
Between 2024-04-09 21:35 UTC and 2024-04-10 19:03 UTC, creation of new Codespaces was degraded by an image upgrade to the virtual machines of new Codespaces. During the incident, approximately 7% of new Codespaces were created but never became available to their owning end users.

We mitigated the incident by reverting to the previous image version. We are working to improve deployment confidence around image upgrades to reduce the likelihood of recurrence.
Posted Apr 10, 2024 - 18:07 UTC
Update
We have applied a fix and are continuing to monitor. This incident will remain open for now until we have confirmed that the service is fully restored.
Posted Apr 10, 2024 - 17:31 UTC
Update
We believe we have identified the root cause of the issue and are working to fully restore the Codespaces service. We will provide another update within the next 30 minutes.
Posted Apr 10, 2024 - 16:56 UTC
Update
We’re seeing issues related to connecting to Codespaces impacting a subset of users. We are actively investigating and will provide another update shortly.
Posted Apr 10, 2024 - 16:20 UTC
Investigating
We are investigating reports of degraded performance for Codespaces
Posted Apr 10, 2024 - 16:12 UTC
This incident affected: Codespaces.