GitHub header
Incident with Copilot
Incident Report for GitHub
Resolved
Between April 15th, 2024 (09:45 UTC) and April 18th, 2024 (19:10 UTC), Copilot completions experienced intermittent periods of degraded service availability affecting portions of Europe and North America, impacting 3.5% of users globally at its peak. This was due to rolling Operating System level maintenance updates to Copilot infrastructure within those regions, which failed to gracefully restart as intended.

The incident was mitigated by routing traffic to other regions, and was resolved once the update was completed and normal traffic routing was restored.

We are working to resolve the root issue that prevented systems from restarting gracefully, as well as improving our coordination and monitoring around backend maintenance operations going forward to reduce time to recovery from such issues in the future.
Posted Apr 15, 2024 - 14:53 UTC
Update
We have applied mitigation for Copilot in EU region and are working towards the full recovery of the service.
Posted Apr 15, 2024 - 14:13 UTC
Update
Due to an outage in one Copilot region traffic is currently being served from other regions. European users may experience higher response times.
Posted Apr 15, 2024 - 13:35 UTC
Investigating
We are investigating reports of degraded performance for Copilot
Posted Apr 15, 2024 - 12:58 UTC
This incident affected: Copilot.