GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub
Resolved
On April 9, 2024, between 04:32 UTC and 05:10 UTC, an outage occurred in Github Packages, specifically impacting the download functionality of NPM Packages. All attempts to download NPM Packages failed during this period. Upon investigation, we found a recent code change in the NPM Registry to be the root cause. The customer impact was limited to users of NPM Registry, with no effects on other registries.

We mitigated the incident by rolling back the problematic change. We are following up with repair items to cover our observability gaps and implementing measures in our CI process to detect such failures early before they can impact customers.
Posted Apr 09, 2024 - 05:10 UTC
Update
We are investigating reports of issues with downloading NPM packages. We will continue to keep users updated on progress towards mitigation.
Posted Apr 09, 2024 - 04:51 UTC
Investigating
We are currently investigating this issue.
Posted Apr 09, 2024 - 04:32 UTC